OVH Community, your new community space.

Mysql accesso remoto


gio01
28.12.2009, 17.59
alla fine hai eseguito il mio consigloio... installare devian e mysql

gio01
24.12.2009, 16.24
inizio dal fatto che l'rps non è adatto per fare questi tipi di lavori
Io pe ril mio progetto ho due macchine
Una macchina fa da mysql installato su sistemi Debian 5.0
Una Macchina con Windows Apache +php5+libmysql+Java
Io cosniglio di fare cosi:
Prendere un dedicato e fare il sito
Se no il rps gli installi un sistema debian e te ne esci ed hosti in quei free host
però ci saranno delle query lunghe quindi per questo preferisco usare i dedicati
.
Un altra cosa: per sicureza non fare MAI database +sito IN UN RPS
se si dovessero dagnneggiare qualcosa quello che ci rimetti sei tu.
Ricapitolando una mano te la posso dare hostando il sito ( gratis )
Se vuoi aiuti contattami via mail
drago021@gmail.com

emanuele
24.12.2009, 16.08
Ho creato un programma java pensato per le ditte Agricole che vogliono permettere ai loro utenti di fare ordini online. Io amministro le ditte creando un database per ognuna di loro. Le ditte accedono col programma java seddetto al loro database e creano tutti gli utenti finali che vogliono coi privilegi ad hoc. Questi utenti finali (compratori) deveno essere in grado di accedere anche loro al database della loro Azienda Agricola con dei privilegi minimi (per fare giusto gli ordini). Il sistema che ho creato (che si compone del programma java per le aziende e di alcuni script php per gli utenti finali) già funziona perfettamente nel mio ambiente di sviluppo a casa.
Ora vorrei trasferire tutto questo su un server acceso giorno e notte.

Il programma Java che ho scritto da una parte cura gli aspetti di inserimento dei dati nel database ma anche tutta una serie di cose che si fanno offline. Tipo stampare etichette. Avrei potuto scrivere la parte verso il database in php anch'essa ma ormai il programma la ingloba e riscrivere tutto in localhost mi richiederebbe tempo.

Spero di averti spiegato un pò cosa vorrei fare e ti ringrazio per il tempo che mi dedichi se hai qualche cosa da consigliarmi.
Emanuele

gio01
24.12.2009, 15.43
ascoltai una cosa: cosa vorresti fare con il rps? che progetti hai? Magari ti posso dare pure dei consigli

emanuele
24.12.2009, 15.41
Ho cercato invano un pannello per questo tipo di modifiche ma non lo trovo.

gio01
24.12.2009, 15.21
Da webmind dovresti credo sbloccar le porte

emanuele
24.12.2009, 15.17
Stesso risultato errore 2003. Io credo di avere dei problemi con le porte.
qui l'output di netstat

> netstat -lnptu
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 2511/tcpserver
tcp 0 0 127.0.0.1:783 0.0.0.0:* LISTEN 2845/
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 2718/couriertcpd
tcp 0 0 0.0.0.0:10000 0.0.0.0:* LISTEN 2978/perl
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 2565/httpd
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 2786/proftpd: (acce
tcp 0 0 94.23.55.34:53 0.0.0.0:* LISTEN 2376/named
tcp 0 0 87.98.182.105:53 0.0.0.0:* LISTEN 2376/named
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 2376/named
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 2556/sshd
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 2514/tcpserver
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 2376/named
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 2565/httpd
udp 0 0 0.0.0.0:10000 0.0.0.0:* 2978/perl
udp 0 0 94.23.55.34:53 0.0.0.0:* 2376/named
udp 0 0 87.98.182.105:53 0.0.0.0:* 2376/named
udp 0 0 127.0.0.1:53 0.0.0.0:* 2376/named
udp 0 0 0.0.0.0:37460 0.0.0.0:* 2376/named

gio01
24.12.2009, 14.56
prova a loggare da navicat

emanuele
24.12.2009, 14.52
Si root può accedere da qualsiasi posizione.

gio01
24.12.2009, 14.49
hai abilitato l'utente root@% ?

emanuele
24.12.2009, 14.39
Ciao gio1

Ho uploadato il file my.cnf con le modifiche nella cartella ma niente e adesso webmin mi dice:

<<
Il programma client di MySQL /usr/bin/mysql sembra non essere della versione corretta. Webmin supporta solo MySQL versione 3 e superiori.

Esecuzione del comando /usr/bin/mysql -V :

/usr/bin/mysql: Can't read dir of '/etc/mysql/conf.d/' (Errcode: 2)
Fatal error in defaults handling. Program aborted
>>

Rimettendo il vecchio my.cnf webmin torna a funzionare.
In bind.address ho messo l'ip del mio server rps1 come mi avevi detto. Ritentando un log da SqlQueryBrowser sempre lo stesso errore 2003.

gio01
24.12.2009, 14.01
aggiungo:
#bind-address = 127.0.0.1 cambialo col tuo ip

gio01
24.12.2009, 12.22
ti posto il mio my.cnf così puoi configurartelo per il meglio
Codice:
#
# The MySQL database server configuration file.
#
# You can copy this to one of:
# - "/etc/mysql/my.cnf" to set global options,
# - "~/.my.cnf" to set user-specific options.
# 
# One can use all long options that the program supports.
# Run program with --help to get a list of available options and with
# --print-defaults to see which it would actually understand and use.
#
# For explanations see
# http://dev.mysql.com/doc/mysql/en/server-system-variables.html

# This will be passed to all mysql clients
# It has been reported that passwords should be enclosed with ticks/quotes
# escpecially if they contain "#" chars...
# Remember to edit /etc/mysql/debian.cnf when changing the socket location.
[client]
port		= 3306
socket		= /var/run/mysqld/mysqld.sock

# Here is entries for some specific programs
# The following values assume you have at least 32M ram

# This was formally known as [safe_mysqld]. Both versions are currently parsed.
[mysqld_safe]
socket		= /var/run/mysqld/mysqld.sock
nice		= 0

[mysqld]
#
# * Basic Settings
#
user		= mysql
pid-file	= /var/run/mysqld/mysqld.pid
socket		= /var/run/mysqld/mysqld.sock
port		= 3306
basedir		= /usr
datadir		= /var/lib/mysql
tmpdir		= /tmp
language	= /usr/share/mysql/english
skip-external-locking
#
# Instead of skip-networking the default is now to listen only on
# localhost which is more compatible and is not less secure.
bind-address		=  EDITA CON IP TUA MACCHINA
#
# * Fine Tuning
#
key_buffer		= 16M
max_allowed_packet	= 16M
thread_stack		= 128K
thread_cache_size	= 8
# This replaces the startup script and checks MyISAM tables if needed
# the first time they are touched
myisam-recover		= BACKUP
#max_connections        = 10000 - EDITA SE VUOI PIu CONNESSIONI TOGLIENDO LO # ED LA MIA SCRITTA
#table_cache            = 64
#thread_concurrency     = 10
#
# * Query Cache Configuration
#
query_cache_limit       = 1M
query_cache_size        = 16M
#
# * Logging and Replication
#
# Both location gets rotated by the cronjob.
# Be aware that this log type is a performance killer.
#log		= /var/log/mysql/mysql.log
#
# Error logging goes to syslog. This is a Debian improvement :)
#
# Here you can see queries with especially long duration
#log_slow_queries	= /var/log/mysql/mysql-slow.log
#long_query_time = 2
#log-queries-not-using-indexes
#
# The following can be used as easy to replay backup logs or for replication.
# note: if you are setting up a replication slave, see README.Debian about
#       other settings you may need to change.
#server-id		= 1
#log_bin			= /var/log/mysql/mysql-bin.log
expire_logs_days	= 10
max_binlog_size         = 100M
#binlog_do_db		= include_database_name
#binlog_ignore_db	= include_database_name
#
# * BerkeleyDB
#
# Using BerkeleyDB is now discouraged as its support will cease in 5.1.12.
skip-bdb
#
# * InnoDB
#
# InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
# Read the manual for more InnoDB related options. There are many!
# You might want to disable InnoDB to shrink the mysqld process by circa 100MB.
#skip-innodb
#
# * Security Features
#
# Read the manual, too, if you want chroot!
# chroot = /var/lib/mysql/
#
# For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
#
# ssl-ca=/etc/mysql/cacert.pem
# ssl-cert=/etc/mysql/server-cert.pem
# ssl-key=/etc/mysql/server-key.pem



[mysqldump]
quick
quote-names
max_allowed_packet	= 16M

[mysql]
#no-auto-rehash	# faster start of mysql but no tab completition

[isamchk]
key_buffer		= 16M

#
# * NDB Cluster
#
# See /usr/share/doc/mysql-server-*/README.Debian for more information.
#
# The following configuration is read by the NDB Data Nodes (ndbd processes)
# not from the NDB Management Nodes (ndb_mgmd processes).
#
# [MYSQL_CLUSTER]
# ndb-connectstring=127.0.0.1


#
# * IMPORTANT: Additional settings that can override those from this file!
#   The files must end with '.cnf', otherwise they'll be ignored.
#
!includedir /etc/mysql/conf.d/
Se non lo capisci bene ti do link

http://www.megaupload.com/?d=O9BGXT9F

questo file va /etc/mysql/

emanuele
24.12.2009, 11.54
Ciao gio01 grazie della risposta. Il file è qui postato ma mi sembra già ok. O Sbaglio?




# /etc/mysql/my.cnf: The global mysql configuration file.
# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/files/my.cnf-4.1,v 1.3 2006/05/05 19:51:40 chtekk Exp $

# The following options will be passed to all MySQL clients
[client]
#password = your_password
port = 3306
socket = /var/run/mysqld/mysqld.sock
character-sets-dir=/usr/share/mysql/charsets
default-character-set=latin1

[php-cgi]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=latin1

[mysql]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=latin1

[mysqladmin]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=latin1

[mysqlcheck]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=latin1

[mysqldump]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=latin1

[mysqlimport]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=latin1

[mysqlshow]
character-sets-dir=/usr/share/mysql/charsets
default-character-set=latin1

[myisamchk]
character-sets-dir=/usr/share/mysql/charsets

[myisampack]
character-sets-dir=/usr/share/mysql/charsets

# use [safe_mysqld] with mysql-3
[mysqld_safe]
err-log = /var/log/mysql/mysql.err

# add a section [mysqld-4.1] or [mysqld-5.0] for specific configurations
[mysqld]
character-set-server = latin1
init-connect='SET NAMES latin1'
default-character-set = latin1
user = mysql
port = 3306
socket = /var/run/mysqld/mysqld.sock
pid-file = /var/run/mysqld/mysqld.pid
log-error = /var/log/mysql/mysqld.err
basedir = /usr
datadir = /var/lib/mysql
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
language = /usr/share/mysql/english

# security:
# using "localhost" in connects uses sockets by default
#skip-networking
#bind-address = 127.0.0.1

log-bin
server-id = 1

# point the following paths to different dedicated disks
tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

# you need the debug USE flag enabled to use the following directives,
# if needed, uncomment them, start the server and issue
# #tail -f /tmp/mysqld.sql /tmp/mysqld.trace
# this will show you *exactly* what's happening in your server

#log = /tmp/mysqld.sql
#gdb
#debug = d:t:i,/tmp/mysqld.trace
#one-thread

# uncomment the following directives if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# the following is the InnoDB configuration
# if you wish to disable innodb instead
# uncomment just the next line
skip-innodb
#
# the rest of the innodb config follows:
# don't eat too much memory, we're trying to be safe on 64Mb boxes
# you might want to bump this up a bit on boxes with more RAM
innodb_buffer_pool_size = 16M
# this is the default, increase it if you have lots of tables
innodb_additional_mem_pool_size = 2M
#
# i'd like to use /var/lib/mysql/innodb, but that is seen as a database :-(
# and upstream wants things to be under /var/lib/mysql/, so that's the route
# we have to take for the moment
#innodb_data_home_dir = /var/lib/mysql/
#innodb_log_arch_dir = /var/lib/mysql/
#innodb_log_group_home_dir = /var/lib/mysql/
# you may wish to change this size to be more suitable for your system
# the max is there to avoid run-away growth on your machine
innodb_data_file_path = ibdata1:10M:autoextend:max:128M
# we keep this at around 25% of of innodb_buffer_pool_size
# sensible values range from 1MB to (1/innodb_log_files_in_group*innodb_buffer_pool_size)
innodb_log_file_size = 5M
# this is the default, increase it if you have very large transactions going on
innodb_log_buffer_size = 8M
# this is the default and won't hurt you
# you shouldn't need to tweak it
set-variable = innodb_log_files_in_group=2
# see the innodb config docs, the other options are not always safe
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
# uncomment the next directive if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

gio01
24.12.2009, 11.46
Loggare a mysql
Fare:

GRANT ALL PRIVILEGES ON *.* TO root@"%" IDENTIFIED BY "";

flush privileges;

Prendere il my.cnf e mettere appsoto di localhost ip della macchina

Ed il gioco è fatto

Se vuoi posta il tuo my.cnf se non riesci lo configuro io =)

emanuele
24.12.2009, 11.40
Salve.
Ho acquistato un RPS1 con il pacchetto Linux di OVh. Tutto funziona egregiamente ma purtroppo dovrei accedere al server SQL in maniera

remota.Ho quindi commentato le due linee in my.cnf
#skip-networking
#bind-address

e riavviato il server.
Ho anche eseguito il comando per abilitare la port 3306 all'esterno

iptables -A INPUT -i eth0 -p tcp --destination-port 3306 -j ACCEPT

Purtroppo non riesco ancora a connettermi in maniera remota ma solo in localhost
Tentando una connessione con Mysqlquerybrowser ottengo sempre l'errore 2003.

Pensando fosse la porta 3306 ho tentato settando la porta di defautl di MySQL a 21 che è per certo attiva sul mio server. In questo caso ottengo l'errore 2013 "Lost connection during query"

Qualcuno potrebbe darmi qualche dritta?

Grazie
Emanuele