OVH Community, your new community space.

Urgente downgrade php da 5.3.3 a 5.2


ciberdany
23.11.2010, 01.42
reinstallato tutto fine

ciberdany
22.11.2010, 19.17
niente con quella disinstallazione sono spariti fisicamente centinaia di file da plesk, è tutto a quel paese per fortuna ho i backup, però non so come recuperare le mail della giornata da poter ripristinare

torpado
22.11.2010, 16.00
in questo caso ti conviene usare l'opzione yum :

--exclude=package
---

rimuovere i package non allineati ed inclusi nelle dipendenze e reinstallarli uno per uno.

ciberdany
22.11.2010, 15.38
ah ho lanciato un yum remove php prima di provare a fare il downgrade come era scritto in una guida, ma nonostante tutto controllando la versione di php mi dice sempre 5.3.3 dalla shell

ciberdany
22.11.2010, 15.34
Ragazzi ho upgradato per errore al php 5.3.3 e ho provato a tornare alla 5.1.6 ho installato il plugin per yum per fare i downgrade, disinstallato php e provato a reinstallare ma mi dice.


php-5.1.6-27.el5.i386 from base has depsolving problems
--> Missing Dependency: php-common = 5.1.6-27.el5 is needed by package php-5.1.6-27.el5.i386 (base)
php-5.1.6-27.el5.i386 from base has depsolving problems
--> Missing Dependency: php-cli = 5.1.6-27.el5 is needed by package php-5.1.6-27.el5.i386 (base)
Error: Missing Dependency: php-cli = 5.1.6-27.el5 is needed by package php-5.1.6-27.el5.i386 (base)
Error: Missing Dependency: php-common = 5.1.6-27.el5 is needed by package php-5.1.6-27.el5.i386 (base)

io ho caricato tutto usando il famoso repository di remi dando poi come upgrade php mysql e php-mysql se non erro

ora son senza php ? però funziona tutto lo stesso non so perchè, ma devo riuscire in pochi minuti a reinstallare la vecchia versione senza rasare il server aiutoooo