OVH Community, your new community space.

Differenti versioni di php sotto stesso hosting


zorzside
09.10.2013, 17.50
Citazione Originariamente Scritto da gaetano.danelli
potrei chiedervi quale comando digitare per php 5.3 e 5.4??
vi ringrazio anticipatamente!
in un file .htacces nella root del sito io metto

SetEnv PHP_VER 4

quindi

SetEnv PHP_VER 5_3

gaetano.danelli
09.10.2013, 17.46
potrei chiedervi quale comando digitare per php 5.3 e 5.4??
vi ringrazio anticipatamente!

zorzside
29.05.2013, 19.25
Io avevo una distribuzione di Zencart vecchissima da importare su ovh ed aggiornare. peccato che zencart 1.3 o hai php 4 o con il 5 non si avvia.

Risolto con l'htaccess.

tmit
13.11.2012, 17.44
Parti dal presupposto che puoi cambiare le versioni usando htaccess come indicato in questa guida: http://guida.ovh.it/printPage/Php5inOVH

In ogni caso se ti può essere di aiuto le versioni caricate attualmente sui webserver sono le seguenti:
Codice:
$ ls -lia /usr/local/bin/php
153468 lrwxrwxrwx 1 root staff 10 Nov  5 02:38 /usr/local/bin/php -> php.ORIG.4

$ ls -lia /usr/local/bin/php.ORIG.4
153297 lrwxrwxrwx 1 root staff 14 Apr 24  2012 /usr/local/bin/php.ORIG.4 -> php.ORIG.4.4.9

$ ls -lia /usr/local/bin/php.ORIG.5
153463 lrwxrwxrwx 1 root staff 12 Jul 20 15:11 /usr/local/bin/php.ORIG.5 -> php.ORIG.5_2

$ ls -lia /usr/local/bin/php.ORIG.5_2
153604 lrwxrwxrwx 1 root staff 15 Jul 20 15:11 /usr/local/bin/php.ORIG.5_2 -> php.ORIG.5.2.17

$ ls -lia /usr/local/bin/php.ORIG.5_3
153603 lrwxrwxrwx 1 root staff 15 Sep  3 12:46 /usr/local/bin/php.ORIG.5_3 -> php.ORIG.5.3.16

$ ls -lia /usr/local/bin/php.ORIG.5_4
153596 lrwxrwxrwx 1 root staff 14 Sep  3 12:46 /usr/local/bin/php.ORIG.5_4 -> php.ORIG.5.4.6

Andreacip
09.11.2012, 17.26
Mi ha appena risposto l'assistenza chiedendomi di creare una cartella di test con dentro l'htaccess con l'istruzione della versione php desiderata.

Così ho fatto e ho caricato il file info.php per controllare la versione, risultato: errore 500 del server!

...sto attendendo notizie...

Andreacip
09.11.2012, 09.04
Nessuno sa darmi qualche conferma?

Andreacip
08.11.2012, 19.28
Buonasera,

ho un hosting premium al quale sto reindirizzando diversi domini.

La domanda è questa: settando il file .htaccess posso utilizzare sotto lo stesso hosting (dominio principale) versioni diverse di php?

Esempio:

www >php 5.3
www/cartella1 >php 5.3
www/cartella2 >php 5.2

Dall'assistenza telefonica mi è stato risposto di si, mentre se carico il file .htaccess in una cartella questa operazione genere subito un errore 500.

Ovviamente cambiando invece l'htaccess nella root del dominio con la versione di php che si desidera funziona tutto correttamente.

Un grazie sentito a chi mi aiuta confermandomi questa domanda, sto aspettando risposta da parte del supporto ma ancora nulla... :-(