OVH Community, your new community space.

Errore 403 Forbidden e Certificato SSL


technofab
29.12.2012, 18.39
Citazione Originariamente Scritto da Penna
In pratica il dominio non cambia, dato che l'unica differenza sarebbe l'https al posto di http.
Prima del fattaccio non avevo fatto questo redirect. Comunque, adesso per fare una prova ho cancellato il comando in questione e:

- il problema a è scomparso;
- il problema b persiste
Vedi i link che ho girato prima, c'è qualche plugin fa uso di ssl?

Mi chiedevo (da ingnorantona quale sono ): potrebbe essere collegato al fatto che mi sono connessa all'ftp in modalità sftp??
MMmmm... potrebbe essere...

Penna
29.12.2012, 18.32
Citazione Originariamente Scritto da technofab
1)

Ad occhio: Problema B collegato a Problema A.
http://wordpress.org/support/topic/p...lem?replies=24
http://wordpress.org/support/topic/s...protocol-error
La Certification Autority sembra non essere coerente.

Ma il redirect cambia il dominio di destinazione? Prima del problema che hai avuto non avevi questo "problema" ?

Problema A: ridomando: ma cambia proprio il dominio di destinazione durante il redirect?
http://www.ovh.it/hosting_web/ssl_hosting.xml
In pratica il dominio non cambia, dato che l'unica differenza sarebbe l'https al posto di http.
Prima del fattaccio non avevo fatto questo redirect. Comunque, adesso per fare una prova ho cancellato il comando in questione e:

- il problema a è scomparso;
- il problema b persiste

Citazione Originariamente Scritto da technofab
2)
Andrebbero visti i permessi in locale. Prova a fare upload di una semplice immagine e prova a richiamarla. Questa immagine però non deve esser parte del backup che stai ripristinando ma una nuova... Forse i files sentono un proprietario differente.
Mi chiedevo (da ingnorantona quale sono ): potrebbe essere collegato al fatto che mi sono connessa all'ftp in modalità sftp??

technofab
29.12.2012, 18.21
1)

Ad occhio: Problema B collegato a Problema A.
http://wordpress.org/support/topic/p...lem?replies=24
http://wordpress.org/support/topic/s...protocol-error
La Certification Autority sembra non essere coerente.

Ma il redirect cambia il dominio di destinazione? Prima del problema che hai avuto non avevi questo "problema" ?

Problema A: ridomando: ma cambia proprio il dominio di destinazione durante il redirect?
http://www.ovh.it/hosting_web/ssl_hosting.xml

2)

Andrebbero visti i permessi in locale. Prova a fare upload di una semplice immagine e prova a richiamarla. Questa immagine però non deve esser parte del backup che stai ripristinando ma una nuova... Forse i files sentono un proprietario differente.

Penna
29.12.2012, 13.44
Buongiorno.

Apro questa nuova discussione perché, anche se derivata da questa (http://forum.ovh.it/showthread.php?t=4798), tratta diverse difficoltà tecniche che non riesco a superare.

Riassumendo, mi era stato cancellato il sito da un lamer. Adesso, dopo aver recuperato il backup e risolto la falla di sicurezza, ho provato a rimettere tutto online, ma ci sono diverse cose che non funzionano.

Prima di elencarle, voglio sottolineare alcuni cambiamenti fatti:

1. utilizzando la guida di Ovh, ho attuato questa modifica:
Potete reindirizzare il vostro dominio automaticamente verso un accesso https attraverso un file .htaccess impostato nella maniera seguente:

Codice:
RewriteEngine On 
RewriteCond %{SERVER_PORT} 80 
RewriteRule ^(.*)$ https://www.domaine.com/$1 [R,L]

Problema a
Effettuando alcuni test da diversi browser, il sito risulta potenzialmente dannoso, in quanto l'indirizzo del certificato di sicurezza utilizzato non corrisponde. Poiché Ovh non consente l'acquisto di SSL, cosa mi consigliate? Posso acquistarlo altrove?

Problema b
In Wordpress ho questo errore:

Codice:
error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol
Potrebbe essere collegato anche questo al problema a?

2. Quando tento di visualizzare il sottodominio del sito mi dà questo errore:

Forbidden

You don't have permission to access /index.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Inizialmente, lo stesso errore si verificava anche con il dominio principale, ma poi mi sono ricordata di aver modificato la password del database in phpmyadmin e modificandola anche nel file wp-config si era risolto tutto.
Poiché il sottodominio utilizza un altro blog Wordpress collegato allo stesso database, ho modificato anche lì la password, ma la situazione non cambia.

Ho svuotato la cache, ma il problema resta.
Ho controllato nell'ftp e i permessi sembrano essere ok: 644 e 755.

La cosa strana è che digitando l'url mi consente l'accesso all'amministrazione di Wordpress, mentre il sito dà sempre lo stesso errore.
Come posso risolvere?

Grazie in anticipo