OVH Community, your new community space.

Configurazione apache


j0t
04.02.2009, 21.25
Citazione Originariamente Scritto da gio01
bene dopo ore di scervellamento ho fatto qst modifica:
ho impostato un autoreindirizzamento su 000-default ad index.html ed index.php
adesso tocca al database che non riescoa fargli uploadare 250 mega
poichè il massimo e di 8.192KB mentre io ho impostato sul file php.ini 3000M ( per evitare rotture )
Devi fare l'upload del database via ftp e poi da linea di comando dare il comando

mysql -u nomeutente nomedatabase < nomefilesql.sql

Ti chiederà la password, tu dagliela, e poi lui importerà i dati...

gio01
04.02.2009, 08.22
bene dopo ore di scervellamento ho fatto qst modifica:
ho impostato un autoreindirizzamento su 000-default ad index.html ed index.php
adesso tocca al database che non riescoa fargli uploadare 250 mega
poichè il massimo e di 8.192KB mentre io ho impostato sul file php.ini 3000M ( per evitare rotture )

gio01
04.02.2009, 07.53
cmq ho installato phpmyadmin ma nn riesco a caricarlo... database che oegsa 250mega....

gio01
04.02.2009, 07.44
ho modificato default così:
Codice:
NameVirtualHost *

	ServerAdmin webmaster@localhost
	
	DocumentRoot /var/www/
	php_value upload_max_filesize 3000M
	
		Options FollowSymLinks
		AllowOverride None
	
	
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
		# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                RedirectMatch ^/$ /
	

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	
		AllowOverride None
		Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined
	ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    

ho notato che c'è un altro file 000-default ma non credo che devo modificare quello?
Codice:
NameVirtualHost *

	ServerAdmin webmaster@localhost
	
	DocumentRoot /var/www/
	
		Options FollowSymLinks
		AllowOverride None
	
	
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
		# This directive allows us to have apache2's default start page
                # in /apache2-default/, but still have / go to the right place
                RedirectMatch ^/$ //
	

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	
		AllowOverride None
		Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined
	ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    


ibanez89
03.02.2009, 22.33
hum come hai modificato la root di apache con il link simbolico? per il massimo upload di mysql cosa intendi? non sono molto ferrato in materia di db sinceramente, ma se devi caricare un backup di database puoi usare phpmyadmin o webmin, se si tratta di un file, installa un client ftp come ad esempio vsftpd

gio01
03.02.2009, 21.27
nuovo problema...
se digito
http://87.98.135.163/ nn vedo nulla
invece se digito
http://87.98.135.163/index.html vedo qualcosa...
come posso fare?

gio01
03.02.2009, 19.59
scusate se vi tormento... vorrei aumentare ilmassimo upload nel database mysql
cioè da 2 mega a 300 mega
help ç_ç

gio01
03.02.2009, 19.33
ehm ci riprovo poi in caso i file che avevo uploadato per ripristinarli? come faccio?
adess mi dice questo errore
La pagina web ha generato un loop di reindirizzamento.

La pagina web http://87.98.135.163/ ha generato troppi reindirizzamenti. Il problema potrebbe essere risolto cancellando i cookie del sito. In caso contrario, potrebbe trattarsi di un errore di configurazione del server e non di un problema del tuo computer.

natran
03.02.2009, 19.09
Dimenticavo, scusate, droppa il file
index.html file nella tua nuova directory ~/www

natran
03.02.2009, 19.08
Ok, prova con questo
Codice:
    
* $ mkdir ~/www
* $ mv /var/www /var/www-backup
* $ ln -s /home/user/www /var/www
Tienici informati

gio01
03.02.2009, 19.01
se sapete come posso aumentare il massimo database da uploadre superiore hai 10 mega ç_ç

gio01
03.02.2009, 18.08
grazie ma nn è questo che cerco... io vorrei che tutto fosse messo su var/www/ no var/www/cartella
vorrei solo questo
mi fa auto redirizione su quella cartella ..

ibanez89
03.02.2009, 17.42
ecco un esempio:

modificare da

Codice:

	ServerAdmin webmaster@localhost
	
	DocumentRoot /var/www/
	
		Options FollowSymLinks
		AllowOverride None
	
	
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    

a

Codice:

	ServerAdmin webmaster@localhost
	
	DocumentRoot /home/ibanez/
	
		Options FollowSymLinks
		AllowOverride None
	
	
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
	

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined

    Alias /doc/ "/usr/share/doc/"
    
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    

scrivendo nel terminale

nano /etc/apache2/sites-available/default

e poi riavviare apache con

/etc/init.d/apache2 force-reload

tutto sempre da root

io mi divertirei anche a creare Alias, ma tutto dipende dalle tue esigenze e tra un pò mi aspettano gli amici, quindi ho fatto una cosa veloce da 30sec

ovviamente ibanez è l'home del mio pc, te dovrai cambiarla

spero di essere stato utile

gio01
03.02.2009, 17.26
se mi dici come forse si potrebbe risolvere qualcosa ç_ç
dove trovare quest funzione e su che file ç_ç

ibanez89
03.02.2009, 17.15
provare a cambiare il documentaryRoot con la cartella che interessa a te "home"? anche se condividere tutta la home genererebbe problemi di sicurezza, quindi crea una cartella dedicata ad apache nella home

gio01
03.02.2009, 17.06
scusate se faccio un altro post devo uppare un database molto pesante ( circa 300 mega ) come lo uppo?

gio01
03.02.2009, 17.00
temporeamente ho fatto un redi di index.php della cartella apache su /index.html normlae sensa la cartella
io vorrei evitare questo passaggio

gio01
03.02.2009, 16.43
allora vorrei che il server redigesse
http://87.98.135.163/
apposto di
http://87.98.135.163/apache ecc ecc
c'è forse qualcosa da settare?
aiuto nn sto capendo + nulla :S

ibanez89
03.02.2009, 16.33
# nano /etc/apache2/sites-available/default

# sta per utente root

EDIT sono stato anticipato

natran
03.02.2009, 16.33
Scusate il post spezzato, forse anche questo link può giovare a risolvere il tuo quesito
http://httpd.apache.org/docs/1.3/urlmapping.html

natran
03.02.2009, 16.28
Forse questo link può essere di tua utilità http://www.yolinux.com/TUTORIALS/ApacheRedirect.html
Tienici informati

gio01
03.02.2009, 16.20
salve ho una distro linux debian... dovrei configuralra affinchè non redirica su apache2-default ma sulla home principale
cosa dovrei fare? vi ringrazio