OVH Community, your new community space.

Caratteri strani nelle email via webmail


technofab
06.02.2013, 13.37
Citazione Originariamente Scritto da ernestonespoli
Grazie tecnofab, per la pazienza.

Il fatto e' che lo fa anche per i pdf e non con tutti.
Sarebbe da indagare se fossero PDF/A quelli "incriminati".

Che tu sappia, c'e' un modo per settare horde in modo da mostrare i messaggi solo in formato testo (un po come avviene con i client di posta, se impostati per non leggere i messaggi in formato html) ?
In questo modo non dovrebbe essere indotto a mostrare gli allegati in formato plein text con i risultati che abbiamo visto.
Stai dicendo questo? http://wiki.horde.org/FAQ/admin/config#toc23

Non so se però comunque anche se vedi in solo formato testo risolveresti, se trattasi di mime.

ernestonespoli
06.02.2013, 13.10
Grazie tecnofab, per la pazienza.

Il fatto e' che lo fa anche per i pdf e non con tutti.
Che tu sappia, c'e' un modo per settare horde in modo da mostrare i messaggi solo in formato testo (un po come avviene con i client di posta, se impostati per non leggere i messaggi in formato html) ?
In questo modo non dovrebbe essere indotto a mostrare gli allegati in formato plein text con i risultati che abbiamo visto.

technofab
05.02.2013, 22.15
A me fa sempre più pensare ad un problema legato al mime type:

http://www.freetutorialssubmit.com/a...ice-files/1436


https://github.com/horde/horde-suppo...ing/mime.types


https://github.com/horde/horde-suppo...ing/mime.globs

ernestonespoli
05.02.2013, 22.09
no, da client non ci sono problemi e l'allegato si vede correttamente. Solo via web con l'interfaccia horde.
Il bello e' che ho anche un altro server (non ovh) con plesk e horde in win 2008 e il problema non si e' mai presentato.
Mentre qui dal primo giorno...

technofab
05.02.2013, 11.13
Rifaccio la domanda, e da client?

ernestonespoli
05.02.2013, 10.28
Citazione Originariamente Scritto da technofab
Sembra un problema mime a come lo descrivi. Da client invece?
da dove lo controllo il "mime a" ?

Ho messo on line lo screenshot di cosa si vede..
http://www.nuovaagenziafunebre.it/problemaposta.gif

Se clicco sulla voce per mostrare i dati , tra le altre info ci sono queste righe:
------------------

[...]

--047d7b5d88efc7a1eb04d4e9252b
Content-Type: multipart/alternative; boundary=047d7b5d88efc7a1e704d4e92529

--047d7b5d88efc7a1e704d4e92529
Content-Type: text/plain; charset=ISO-8859-1

QUESTO E' IL SOGGETTO DEL MIO MESSAGGIO

--047d7b5d88efc7a1e704d4e92529
Content-Type: text/html; charset=ISO-8859-1


QUESTO E' IL SOGGETTO DEL MIO MESSAGGIO

--047d7b5d88efc7a1e704d4e92529--
--047d7b5d88efc7a1eb04d4e9252b
Content-Type: application/vnd.openxmlformats-officedocument.wordprocessingml.document;
name="il mio file allegato.docx"
Content-Disposition: attachment;
filename="il mio file allegato.docx"
Content-Transfer-Encoding: base64
X-Attachment-Id: f_hcrvg2gb0

UEsDBBQABgAIAAAAIQDd/JU3ZgEAACAFAAATAAgCW0NvbnRlbnRfVHlwZXNdLnhtbCCiBAI ooAAC
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA AAAAAAAAAAAAAAAAAAAAAAA
....
[prosegue con i caratteri strani]

In altri messaggi dove il problema non si presenta, c'e' un avviso su fondo giallo che dice:
"Non ci sono porzioni alternative che possono essere mostrate inline."
oppure
"Questo messaggio è stato scritto con un set di caratteri (UTF-8) diverso dal tuo
Se non è visualizzato correttamente, Clicca qui per aprirlo in una nuova finestra
Mostra questo HTML in una nuova pagina?"

Quindi credo che sia una qualche impostazione di Horde ma non ho capito dove va modificata.

technofab
05.02.2013, 07.02
Sembra un problema mime a come lo descrivi. Da client invece?

ernestonespoli
04.02.2013, 22.54
E' la prima volta che mi capita di vedere i messaggi via webmail (Horde istallato in automatico con il Plesk su server dedicato Win2008) con gli allegati mostrati inline.
In pratica dopo il testo del messaggio, non sempre, vengono mostrati gli allegati come se fossero aperti con il blocco note (tutta una fila di caratteri strani tipo : UEsDBBQABgAIAAAAIQDd/JU3ZgEAACAFAAATAAgCW0)

Non sempre, e non con tutti i tipi di file (capita qualche volta con .docx o pdf).

Come si puo' evitare che mostri queste cose ?

ciao a tutti