OVH Community, your new community space.

Configurazione domini esterni e interni verso il server dedicato


mondopallone
03.04.2013, 14.41
ho risposto alla mail del supporto cos continuo di l, grazie di nuovo!

mondopallone
03.04.2013, 14.21
Allora guardo rimuovo le info "private" da qui come mi hai detto e sto aprendo un ticket al supporto, ti anticipo che non sono collegato al server e ping non li sto facendo da l, per quello che sono un po' confuso su quello che sta succedendo, scrivo al supporto ora con la speranza di lavorare con te al ticket

azrael666x
03.04.2013, 14.17
Scusa, ma credo che qui ci sia un problema di comprensione.

Il dominio mondopallone.com ha impostati i seguenti DNS:

Domain Name: MONDOPALLONE.COM
Name Server: KS######.KIMSUFI.COM (il tuo server)
Name Server: NS.KIMSUFI.COM
Ma se faccio un controllo sul DNS primario, ottengo questo:

dig mondopallone.com @ks######.kimsufi.com

; <<>> DiG 9.8.1-P1 <<>> mondopallone.com @ks######.kimsufi.com
;; global options: +cmd
;; connection timed out; no servers could be reached
Quindi non c' nessun DNS che risponde = Nessuna propagazione = Nessun dominio visibile su internet.

Se provo a cercare il tuo dominio, sia da rete Telecom che da rete Fastweb, ottengo solo errori di dominio irraggiungibile.

Come fai a dire che funziona? Non che sei collegato sul server e fai il ping da li e le verifiche da li?
ping mondopallone.com
PING mondopallone.com.ovh.it (###.###.###.###) 56(84) bytes of data.
^C
--- mondopallone.com.ovh.it ping statistics ---
28 packets transmitted, 0 received, 100% packet loss, time 26999ms

e

ping www.mondopallone.com
PING www.mondopallone.com.ovh.it (###.###.###.###) 56(84) bytes of data.
^C
--- www.mondopallone.com.ovh.it ping statistics ---
22 packets transmitted, 0 received, 100% packet loss, time 20999ms
Tra l'altro, ti consiglio di rimuovere i dati del tuo server e gli IP dal forum, nel caso contattaci al supporto.

mondopallone
03.04.2013, 14.08
ALT, prima ho detto che non funzionava pi ma ero collegato da casa durante la pausa pranzo, ora son tornato in ufficio e da qui infatti funziona.

E' questione di propagazione dei DNS?

mondopallone
03.04.2013, 13.29
il .com di cui parlo mondopallone.com che giuro era funzionante fino a mezz'ora fa, al ping rispondeva il mio server e da web pure visualizzavo il sito correttamente, ora non va pi

Vi scrivo tramite il supporto allora perch c' qualcosa che non mi torna...

azrael666x
03.04.2013, 13.20
Non mi risulta che il tuo dominio .com sia raggiungibile in rete.

Se non sai come configurare un server DNS, ti consiglio vivamente di utilizzare i DNS che OVH ti ha fornito per i domini.

Potrai ovviamente modificare il record A della zona DNS dei tuoi domini inserendo l'IP del server.

Eventualmente contattaci al supporto per maggiori informazioni.

mondopallone
03.04.2013, 11.53
Citazione Originariamente Scritto da azrael666x
La configurazione del DNS primario la devi fare sul server direttamente.

Prova a verificare e disabilita il firewall, una volta che la configurazione sar assolutamente corretta, potrai riabilitare il firewall e verificare se il problema dipende da una errata configurazione del firewall o del DNS primario.
In tutta onest sul server non ho configurato nulla per quanto riguarda il DNS, sono uno sviluppatore web di professione, con un po' di conoscenza obbligatoria di server windows, ma su linux sono alle prime armi, quindi chiedo perdono se faccio domande stupide

Perch senza far nulla il .com funziona correttamente (pur dando errore nel manager OVH)? forse perch il dominio appartiene gi al circuito OVH?

Ti ringrazio,
Fabio

azrael666x
03.04.2013, 11.35
La configurazione del DNS primario la devi fare sul server direttamente.

Prova a verificare e disabilita il firewall, una volta che la configurazione sar assolutamente corretta, potrai riabilitare il firewall e verificare se il problema dipende da una errata configurazione del firewall o del DNS primario.

mondopallone
03.04.2013, 10.58
Citazione Originariamente Scritto da azrael666x
Da quanto posso vedere, il tuo server non configurato per il tuo dominio:

dig fabioradwan.me @###.###.###.###

; <<>> DiG 9.8.1-P1 <<>> fabioradwan.me @###.###.###.###
;; global options: +cmd
;; connection timed out; no servers could be reached

Quindi le cose sono due:
- la configurazione stata fatta in maniera errata;
- la configurazione non stata fatta o c' qualche firewall che blocca la comunicazione in uscita.

Se il tuo server ha installato bind, puoi appoggiarti a questa guida:
http://guida.ovh.it/GestioneBind
Ciao,

Grazie per la celere risposta. Immagino appunto che ci sia qualche errore nella configurazione, ma tu intendi nel server fisico o nel manager di OVH?

La cosa strana di cui non mi capacito che per un po' ha funzionato, senza che io facessi modifiche, dopo ha smesso. Per quanto riguarda il Firewall ho installato CSF, mi viene il dubbio che quando funzionava non lo avevo ancora abilitato?

Posso provare a disabilitarlo un attimo e vedere come cambia la situazione magari.

Grazie,
Fabio

azrael666x
03.04.2013, 10.45
Da quanto posso vedere, il tuo server non configurato per il tuo dominio:

dig fabioradwan.me @###.###.###.###

; <<>> DiG 9.8.1-P1 <<>> fabioradwan.me @###.###.###.###
;; global options: +cmd
;; connection timed out; no servers could be reached

Quindi le cose sono due:
- la configurazione stata fatta in maniera errata;
- la configurazione non stata fatta o c' qualche firewall che blocca la comunicazione in uscita.

Se il tuo server ha installato bind, puoi appoggiarti a questa guida:
http://guida.ovh.it/GestioneBind

mondopallone
03.04.2013, 10.26
Ciao a tutti,

Mi scuso se apro un nuovo thread ma trovo alcune info sparse qu e l in alcuni thread e a volte senza una risposta finale, perch magari l'utente ha risolto tutto e quindi il thread finito l.

Allora la mia situazione semplice, ho comprato un server dedicato kimsufi e un dominio che mi servito solo per "bloccare" l'estensione del dominio originale .it che invece su aruba. Su Ovh ho comprato appunto il .com per bloccarlo, e per fare comunque del testing.

Il server kimsufi quasi pronto, ho installato pi o meno tutto e mi servirebbe solo ottimizzarlo un po' per quanto riguarda mysql e apache, a proposito se avete qualche link di riferimento ben accetto.

Vorrei ora far puntare il dominio acquistato su OVH sul server dedicato, e finalmente penso di esserci riuscito, dopo aver impostato i DNS ora se pingo il dominio risponde il server kimsufi. Ho poi impostato il virtual host su apache e tutto funziona, il dominio punta correttamente al sito configurato il server. Evvai!

Ora, tra le varie operazioni che ho fatto, e che ho letto sul forum stata quella di impostare il DNS secondario sul server kimsufi, solo che non mi chiara se un'operazione obbligatoria o meno, in alcuni thread mi sembrato di capire che serve solo per i domini .it? Qui c' il problema quindi, sia il dominio acquistato su OVH che un altro dominio che ho comprato su GoDaddy risultano in errore nella schermata del DNS secondario, questo uno screenshot:


www.fabioradwan.me appunto il dominio acquistato su GoDaddy, nel pannello DNS di quel dominio ho impostato gi da qualche giorno i NS correttamente e un A record che punta all'IP del server. Il dominio ancora non risponde per al ping, la cosa strana che qualche giorno fa dopo aver impostato i DNS funzionava (non avevo neanche impostato il DNS secondario dal manager di OVH) ma poi ha smesso di funzionare da solo.

La mia richiesta quindi : perch quegli errori?

Qualcuno riesce a riassumere i punti obbligatori per la corretta configurazione?

Nel breve termine dovr convertire l'hosting condiviso di Aruba (che ho menzionato all'inizio) a una gestione dominio + DNS per far puntare il dominio al server kimsufi. A tal proposito, se qualcuno ha dei consigli di "best practice" da fornire ne sarei grato perch vorrei evitare minuti o addirittura ore di down del sito visto che importante per quello che facciamo.

Un grazie a tutti!
Fabio