OVH Community, your new community space.

Problemi Ricezione Email


fucine
18.02.2014, 17.01
Diciamo la verità: per fare hosting serio forse Plesk non è la soluzione migliore. Passare, allo stesso costo di licenza, a WHM/cPanel è decisamente meglio, anche per lasciar stare qmail una volta per tutte ed usare MTA più performanti tipo Exim/Dovecot e Postfix (che pur Plesk offre, ma non di default). Per non parlare, poi, dell'editor di configurazione ACL Exim che WHM mette a disposizione.
Analisi comparativa tra Postfix, Exim, qmail, Sendmail: http://shearer.org/MTA_Comparison
Ad comcludendum:
- Postfix is secure and modern; qmail is secure but very old and cranky; Exim is secure to different criteria
- Postfix can run milters; can use equivalent Exim routers/filter script

mac
06.02.2014, 18.41
Citazione Originariamente Scritto da Giovanni0
Penso, che avere dei problemi relativi alla posta non sia da attribuire a "non saper gestire un server".
Visto il modo in cui hai esposto il problema e le soluzioni che hai "tentato", direi proprio di si.
Non prenderla come una critica, era solo un consiglio.
Il server è tuo e puoi fare come ti pare, ci mancherebbe altro.

Citazione Originariamente Scritto da Giovanni0
Non ho avuto mai questi problemi, ho semplicemente cambiando il puntamento dell'ip del vecchio server sul nuovo.
Solitamente dovrebbe essere tutto di default configurato, basta creare le caselle di posta elettronica associati ai domini..
Ah, se lo dici tu

Kaos
06.02.2014, 17.33
anche... ma la comodità di impostare i client di posta con "mail.sito.com" è qualcosa di buono, "eh ma potrei usare direttamente sito.com", si vero nel tuo caso. Il server di posta potrebbe essere altrove.

Giovanni0
06.02.2014, 17.30
Citazione Originariamente Scritto da Kaos
Non è un problema ma concettualmente non ha senso, sono delle informazioni ridondanti. Io inoltre metterei soltanto a 1:mail.sito.com. Si potrebbe dire "eh ma se il server dns va a ...., non funzionerebbe più", risponderei ok, allora al massimo aggiungi 5:ip come record.
Al momento penso di lasciarlo così,
in modo se il dns non funziona, farà riferimento sempre all'ip.

Sicuramente non ha senso, ma ha probabilmente più senso togliere il puntamento al dns eliminando anche il record A ...
che ne pensi?

Detto ciò, per il resto funziona tutto alla perfezione

Kaos
06.02.2014, 15.18
Non è un problema ma concettualmente non ha senso, sono delle informazioni ridondanti. Io inoltre metterei soltanto a 1:mail.sito.com. Si potrebbe dire "eh ma se il server dns va a ...., non funzionerebbe più", risponderei ok, allora al massimo aggiungi 5:ip come record.

Giovanni0
06.02.2014, 14.49
Citazione Originariamente Scritto da mac
Secondo me è da pazzi gestire un server se non sai nemmeno quello che stai facendo.
Ti consiglio di consultare un sistemista.

Saluti
Penso, che avere dei problemi relativi alla posta non sia da attribuire a "non saper gestire un server".

Non ho avuto mai questi problemi, ho semplicemente cambiando il puntamento dell'ip del vecchio server sul nuovo.
Solitamente dovrebbe essere tutto di default configurato, basta creare le caselle di posta elettronica associati ai domini..


Citazione Originariamente Scritto da kaos
Curiosità, noti niente di strano in /usr/local/psa/admin/logs/panel.log ?
Tra l'altro, perchè usi due record mx con la stessa priorità? (seppur puntino allo stesso server)
Non ho nessun errore nel file di log citato..
Comunque ho notato che ricevo ora la posta anche sulle altre email, ma non riesco a farlo da un'indirizzo specifico che ho configurato su outlook, probabilmente è un problema legato ad outlook..
dopo proverò a chiuderlo e riaprirlo..

per quanto riguarda i 2 record mx, ho aggiunto un secondo con un dominio: mail.dominio.it che punta al record A che punta allo stesso IP.
Se pensi sia "inutile" posso anche toglierlo..

Ps: grazie Kaos.

Saluti.

Kaos
06.02.2014, 14.36
Curiosità, noti niente di strano in /usr/local/psa/admin/logs/panel.log ?
Tra l'altro, perchè usi due record mx con la stessa priorità? (seppur puntino allo stesso server)

mac
06.02.2014, 14.15
Secondo me è da pazzi gestire un server se non sai nemmeno quello che stai facendo.
Ti consiglio di consultare un sistemista.

Saluti

Giovanni0
06.02.2014, 12.22
Citazione Originariamente Scritto da Kaos
Salve,
grazie per la risposta.

il problema si è risolto su un dominio, avviando il processo: mchk - che ha resettato le impostazioni delle caselle email. e il servizio qmail.

inviando email al secondo account, continua ad uscirmi lo stesso errore:

all relevant MX records point to non-existent hosts or (invalidly) to IP addresses

ho controllato le impostazioni dns e risultano identiche al precedente con il dominio differente ovviamente..

avviando un test da dnsstuff mi spunta questo errore:

37.59.0.198 | unexpected response to [RCPT TO: ] | 550 sorry, no mailbox here by that name. (#5.7.17)

che cosa dovrei fare?
Alcuni consigliano di eliminare l'host dal file virtualdomains.. l'ho fatto e riavviato il servizio qmail ma non succede niente..
l'ho ovviamente rimesso come per l'altro dominio che funziona ma non riesco a risolve..

Attendo una vostra risposta.
Thanks.

Kaos
06.02.2014, 10.50
http://kb.parallels.com/en/1380

Giovanni0
06.02.2014, 10.15
Citazione Originariamente Scritto da Kaos
Grazie per la risposta,
seguendo la guida, ho visto che i domini erano dentro il file locals,

li ho tolti, riavviati il qmail ed ora questa è la situazione:

Invio un'email alle email in questione, rispettivamente a 3 caselle di posta:

mi ritorna indietro soltanto un messaggio d'errore relativo ad una casella di posta con il seguente errore:
Sorry. Although I'm listed as a best-preference MX or A for that host, it isn't in my control/locals file, so I don't treat it as local. (#5.4.6)

Non capisco perchè non mi da errore anche delle altre,
dovrebbe essere ok, ma non ricevo nessuna email nelle caselle interessate.. why?

Attendo una vostra risposta.
Grazie mille.

Thanks.

Kaos
06.02.2014, 08.33
Guarda qua: http://kb.parallels.com/en/797

Giovanni0
05.02.2014, 22.01
Salve,
ho un problema relativo ( sicuramente ) alla configurazione delle email e dei servizi relativi alla posta che hosta nel nuovo server OVH.

Ho acquistato 2 domini che risiedono in un'altra compagnia di hosting e ho fatto puntare gli ip dei relativi domini ai nuovi server.
I siti funzionano correttamente dopo la migrazione però ho dei problemi con la posta che non riesco a risolvere.

Sul plesk del nuovo server OVH ho creato i domini e ho creato le caselle di posta:

1. servizioclienti@sitotest1.it
2. webmaster@sitotest2.it

Riesco da entrambi a mandare la posta verso altre caselle di posta sia dal webmail del server che da un software di posta ( outlook ).

Se provo invece, ad inviare la posta verso queste email, mi restituisce subito un'errore:

questo sulla prima email:
Sorry, no mailbox here by that name. (#5.1.1)

questo sulla seconda email:
all relevant MX records point to non-existent hosts or (invalidly) to IP addresses

Ho fatto un pò di ricerche su internet e ho trovato come suggerimento di accettarmi che i domini fossero inseriti all'interno dei relativi file di qmail/control/, rispettivamente: virtualdomains, rcpthosts.

Probabilmente non è questo il problema ? non lo so.. non ne sto capendo più niente..

Ho fatto dei test con dnsstuff.com e i test sono tutti positivi,
i parametri MX ed A, puntano entrambi allo stesso ip e al relativo sotto dominio mail.dominio.it

Non capisco perchè non debbano funzionare.

Ribadisco, funziona l'invio delle email, ma non riesco a ricevere e se qualcuno prova ad inviare gli spunta quell'errore..

Gli account di posta sono stati attivati su entrambi i domini e riesci ad accedere da webmail.

Avete qualche suggerimento? test da fare?
Sono nelle vostre mani ..

Ps: i domini in questione sono i seguenti:
ilcercaprezzi.it
offertedelmomento.it

Saluti
Giovanni