OVH Community, your new community space.

Ogni Newsletter inviata viene vista come SPAM


filippobn
27.03.2014, 17.36
ime;
Ti premetto che io lo faccio per mestiere e ti posso garantire una cosa ardila della configurazione email Andrano a finire sempre in spam ovviamente se la configurazione è errata prima o poi verrai filtrato dagli antispam dei vari provider e non arriveranno piu a destinazione ti ho chiesto quante email invii perché in base al ip che hai risulta una reputazione pessima 13 percento su 100 questo vuol dire che pure se avrai una buona configurazione cmq sarai filtrato.
Quindi ti consiglio prima di tutto di cambiare ip fare tutta la configurazione da capo e magari invece di usare webadmin ti consiglio cpanel con i nameserver proprietari in modo che se cambia qualcosa cpanel te lo rigenera in automatico. Se poi vuoi essere fatto una configurazione a doc posso farti un preventivo contatami su skpe al nick nonsoloprogrammi

ime
27.03.2014, 16.34
Citazione Originariamente Scritto da filippobn
Be prima di tutto ti consiglio di impostare il reverse:
mi risulta che sia
Hostname ns211453.ip-188-165-213.eu
Domain ip-188-165-213.eu

Poi che panello usi? quande email invii?
Spf lai impostato bene?dkim?
ciao Filippo e grazie per la risposta...
allora, il reverse l'ho impostato ma, essendo totalmente diverso da quello postato da te, credo che sia completamente sbagliato...stasera proverò a variarlo seguendo le tue impostazioni...

per quanto riguarda SPF e DKIM, li ho impostati ma credo che siano errati anch'essi, il mio SPF è così
mail-tester.com.istitutoime.it. SPF Default v=spf1 a mx ip4:188.165.213.195 ~all
credendo che sia sbagliato ne ho impostato anche un altro
istitutoime.it. SPF Default v=spf1 a mx ip4:188.165.213.195 ~all
ma credo che sia errato anche questo perchè acymailing continua a dirmi che non è presente nessun record SPF.

il record DKIM invece, l'ho impostato così
acy._domainkey.istitutoime.it. TXT Default v=DKIM1;s=email t=s;p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQClZE87 Atp[...snip]
ma anche in questo caso non ne esco vivo...

il pannello che utilizzo è WEBADMIN (quello di default di OVH) e di email ne ho inviate una decina...tutte singole e tutte in spam!
Porca miseria, non è la prima volta che seguo un VPS...ma questa è la prima volta che ho tutti 'sti problemi...
Ciao e grazie.

filippobn
26.03.2014, 17.36
Be prima di tutto ti consiglio di impostare il reverse:
mi risulta che sia
Hostname ns211453.ip-188-165-213.eu
Domain ip-188-165-213.eu

Poi che panello usi? quande email invii?
Spf lai impostato bene?dkim?

ime
26.03.2014, 10.50
Ancora un piccolissimo UP...

ime
25.03.2014, 09.22
Piccolo UP...strano che nessuno abbia avuto gli stessi problemi... vuol dire che mi è capitato un VPS sfortunato?

ime
23.03.2014, 13.50
ciao a tutti,
del problema originale, dove tutte le mail finivano nella cartella SPAM quando inviate ad indirizzi GMAIL, grazie all'intervento di Torpado (OVH Team) sono riuscito a risolvere la problematica dell'invio mail di registrazione e conferma iscrizione, ora tutte vanno a buon fine.

Però il problema è risolto solo a metà, in quanto, anche le Newsletter finiscono in SPAM.
Non me ne sono accorto prima perchè pensavo che anche le NL soffrissero dello stesso problema delle altre mail: venivano spedite con indirizzo IP versione 6 invece che con IPv4.
Invece non è così, mentre le mail vanne bene, ad ogni controllo delle mie newsletter fatto con lo "spam test" di AcyMailing (Joomla), il punteggio che raggiungo è sempre intorno ai 3 su 10.

I 7 punti persi sono dovuti in gran parte alla firma DKIM e al record SPF che, pur essendoci e sembrando corretti, non vengono riconosciuti dal sistema di controllo "Spam Test", il quale mi passa i seguenti consigli:

SPF:
"Sender Policy Framework (SPF) is an email validation system designed to prevent email spam by detecting email spoofing, a common vulnerability, by verifying sender IP addresses.

You do not have a SPF record, please add the following one to your domain mail-tester.com:

v=spf1 a mx ip4:188.165.213.195 ~all" (questo mi fa perdere 1 punto)


SENDER ID:
"Sender ID is like SPF, but it checks the FROM address, not the bounce address.

You do not have a SPF record, please add the following one to your domain istitutoime.it:

v=spf1 a mx ip4:188.165.213.195 ~all" (Altro punto perso)


DKIM:
"The DKIM signature of your message is:

v=1;
a=rsa-sha1;
q=dns/txt;
l=6343;
s=acy;
t=1395577555;
c=relaxed/simple;
h=from:to:subject;
d=istitutoime.it;
bh=re6RLlOImanBci7UEpYuE5/W6X4=;
b=Hp5YJGXAdd/lXgoEih2vRM5NJMB3VLA3Zod8cVL8HOEpTYqCxCITPWga15waF 4VmgT2AmNsBaTmc+kegRTsiJRM6Tj8l6Q/492KsijFNY64caUDPl0ptLZ4/8uh+WpgZ4duczx74lX/Qqq3GGbRyU8BGJouR8SZJOUoLM7wGkxc=

We were not able to retrieve your public key.
Please ensure that you inserted your DKIM TXT DNS record on your domain istitutoime.it using the selector acy.
If you recently modified your DNS, please be patient and test again your Newsletter in 12 hours, it may take some time for the DNS to be propagated" (Questo mi fa perdere ben 3 punti)

PROVO A RICAPITOLARE:
SPF: il sistema mi dice che non ho un record SPF e mi dice di inserirne uno che mi passa lui...lo inserisco e nell'interfaccia di OVH appare così:
mail-tester.com.istitutoime.it. SPF Default v=spf1 a mx ip4:188.165.213.195 ~all
ovviamente il mio dominio NON è mail-tester.com ma istitutoime.it, per cui il record non viene riconosciuto
Per sicurezza ne ho inserito un altro in questo formato:
istitutoime.it. SPF Default v=spf1 a mx ip4:188.165.213.195 ~all
ma anche in questo caso non funziona...

poi mi viene detto di mettere un SENDER ID, che è uguale al record SPFma ne controlla solo l'indirizzo DA e non l'indirizzo di BOUNCE...
Cooooosaaaaa?
Consigli?

e per finire la parte più importante, quella che mi fa perdere di più, il record DKIM.
Acymailing (in joomla) mi passa i valori da inserire come chiave e valore, che io copio e incollo creando questo record:
acy._domainkey.istitutoime.it. TXT Default v=DKIM1;s=email t=s;p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQClZE87 Atp[...]

ma ad un nuovo controllo mi viene comunicato che non iene riconosciuta la chiave pubblica e che non ho un record DKIM...
sto diventando matto...consigli?
ciao e grazie.