OVH Community, your new community space.

spazio backup in nfs


mac
14.04.2014, 14.45
Sarebbe bello sapere (da OVH) se questo comportamento, montando lo spazio in NFS, è normale oppure no.
La guida ufficiale non parla di parametri particolari per il mount, ma con quelli standard c'è qualcosa che non va... bisogna fose limitare la banda?

Paul
10.04.2014, 16.40
Prove analoghe con risultati analoghi per 2 server diversi. Pero' mi sono limitato al mount NFS semplice.
Noto anch'io velocita' che varia ampiamente ed inoltre, noto che non mi permette di settare gli attributi di quanto copio, sicche' mi perdo owner/group dei files trasferiti. Cosa seccante in fase di ripristino se sono tanti files e che rende nullo il vantaggio di NFS rispetto ad un mount FTP.

Grazie, P.

mac
09.04.2014, 11.35
Salve,
sto cercando di utilizzare lo spazio di backup fornito con il server, montandolo come NFS.

Ho visto questa guida:
http://guida.ovh.it/BackupFTP
però segnalo che contiene un errore, in particolare
Codice:
mount -t nfs FTPBACKUPHOST:/export/Backup storage/NAMESERVER /DOSSIERMOUNT
"Backup storage" in realtà deve essere "ftpbackup", come indicato nella versione originale della guida francese:
http://guide.ovh.com/backupftp
In questo modo, riesco senza problema a montare lo spazio di backup in nfs.

Il problema però è che quasi impossibile utilizzarlo, in quanto dopo un po' i trasferimenti sono incredibilmente lenti.
O meglio, partono velocemente (~100MB/s) per poi crollare improvvisamente a qualche decina di KB/s
Per completezza aggiungo che per fare le prove ho provato a copiare delle immagini di backup di macchine virtuali della dimensione di qualche decina di GB. Ho usato sia "cp" che "rsync".
Ho provato inoltre a montare il fs come suggerito dalla guida e anche con altre opzioni di mount, come "nolock", "async", passare alla versione 3, alzare ed abbassare "rsize" e "wsize", ma con scarsi risultati.
Dopo qualche GB copiato, il trasferimento diventa lentissimo, per poi riprendere dopo un po' e poi tornare lento... ecc...
Monitorando con iotop, ho notato che il processo che copia (ad esempio cp o rsync), ha un valore di IO> prossimo al 99%
Chiedo quindi: ci sono delle opzioni di mount particolari da dare per montarlo in modo corretto?
Io sto usando quelle di default (di un server con proxmox) che sono:
Codice:
type nfs4 (rw,relatime,vers=4,rsize=262144,wsize=262144,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=188.165.xxx.xxx,minorversion=0,local_lock=none,addr=178.33.xxx.xxx)
Altri suggerimenti?
Qualcuno che lo ha fatto funzionare decentemente?

grazie