OVH Community, your new community space.

Centos - plesk-php-cleanuper e problemi in aggiornamento


Mauro Soligo
02.05.2014, 08.34
Ciao a tutti, da qualche giorno ho un messaggio per e-mail che mi avvisa di una procedura che fallisce:
*****************
/etc/cron.hourly/plesk-php-cleanuper:
pgrep: error while loading shared libraries: libproc-3.2.8.so: wrong ELF class: ELFCLASS32

*****************

Sono andato a vedere lo script plesk-php-cleanuper e cio che da problemi il comando "pgrep" ( per la precisione nella stringa "pgrep -f ".*$0$" | grep -qv $$ && exit 0" )

Se lancio da console pgrep ottengo:
*******************
pgrep: error while loading shared libraries: libproc-3.2.8.so: wrong ELF class: ELFCLASS32
*******************

Cercando in rete dicono di lanciare questo comando ( e per sintesi riporto subito l'output relativo ):

rpm -qa --qf '%{name}-%{version}.%{release}.%{arch}\n' glibc\*
glibc-2.12.1.132.el6.x86_64
glibc-headers-2.12.1.132.el6.x86_64
glibc-common-2.12.1.132.el6.x86_64
glibc-devel-2.12.1.132.el6.x86_64
glibc-2.12.1.132.el6.i686



Il problema sembra essere che inspiegabilmente ( non mi ero mai collegato al server che ho da poco e non ho mai fatto aggiornamenti o pasticci vari ) ci sono due versioni di glibc ( 32 e 64 bit ).

ho provato con yum update ma non riesco a risolvere, per la precisione se ora lo lancio ecco cosa ottengo


Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* atomic: mir01.syntis.net
* base: mirror.ovh.net
* extras: mirror.ovh.net
* updates: mirror.ovh.net
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package coreutils.x86_64 0:8.4-19.el6_4.2 will be updated
---> Package coreutils.x86_64 0:8.4-31.el6_5.1 will be an update
---> Package psmisc.x86_64 0:22.6-15.el6_0.1 will be updated
---> Package psmisc.x86_64 0:22.6-19.el6_5 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ========
Package Arch Version Repository Size
================================================== ========
Updating:
coreutils x86_64 8.4-31.el6_5.1 updates 3.0 M
psmisc x86_64 22.6-19.el6_5 updates 81 k

Transaction Summary
================================================== ========
Upgrade 2 Package(s)

Total download size: 3.1 M


e se procedo

Downloading Packages:
(1/2): coreutils-8.4-31.el6_5.1.x86_64.rpm | 3.0 MB 00:00
(2/2): psmisc-22.6-19.el6_5.x86_64.rpm | 81 kB 00:00
---------------------------------------------------------------
Total 10 MB/s | 3.1 MB 00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : coreutils-8.4-31.el6_5.1.x86_64 1/4
Error unpacking rpm package coreutils-8.4-31.el6_5.1.x86_64
error: unpacking of archive failed on file /bin/ls: cpio: rename
Updating : psmisc-22.6-19.el6_5.x86_64 2/4
Error unpacking rpm package psmisc-22.6-19.el6_5.x86_64
error: unpacking of archive failed on file /usr/bin/pstree: cpio: rename
coreutils-8.4-19.el6_4.2.x86_64 was supposed to be removed but is not!
Verifying : coreutils-8.4-19.el6_4.2.x86_64 1/4
psmisc-22.6-15.el6_0.1.x86_64 was supposed to be removed but is not!
Verifying : psmisc-22.6-15.el6_0.1.x86_64 2/4
Verifying : psmisc-22.6-19.el6_5.x86_64 3/4
Verifying : coreutils-8.4-31.el6_5.1.x86_64 4/4

Failed:
coreutils.x86_64 0:8.4-19.el6_4.2 coreutils.x86_64 0:8.4-31.el6_5.1 psmisc.x86_64 0:22.6-15.el6_0.1 psmisc.x86_64 0:22.6-19.el6_5

Complete!


Qualcuno gi incappato in questo problema?

L'unica cosa che ho fatto ( ma l'assistenza mi ha detto che era completamente trasparente ) stato fare l'upgrade dal piano "VPS Classic 1" con cui sono partito per conoscere il servizio al "VPS Classic 2" che ha due core.