We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Problema con Wordpress (WP Remote Get)


Epyka
28.07.2014, 12.27
Fatto e non funziona comunque. Direi che sia arrivato il momento di omettere il plugin social e di utilizzare dei codici appositi dati da quest'ultimi. Facebook è l'unico che da problemi, sempre. Vi ringrazio per il supporto datomi finora e se non avete altre idee, potete chiudere.

Preliator
25.07.2014, 16.46
Ma provare su un'installazione pulita? installi un'altro wp in una sottocartella del sito e provi li...

Epyka
25.07.2014, 15.40
Citazione Originariamente Scritto da Preliator
Ohllallà com'è suscettibilein teoria dovrebbe fare il redirect automatico se si omette l'https e invece il fatto che non c'era, per wp, era come se indirizzasse ad un altro sito che ovviamente non conteneva le tue informazioni richieste... comunque dal debug sembra che il problema fosse prettamente di plugin. Quindi wp ne ovh c'entrava nulla... e difatto...
Ehm... direi che il problema è ritornato: counter a 0 dopo 24 ore (si aggiorna ogni 4 ore, quindi è durata un po' la modifica). Ora: Ho aperto il link "graph.facebook.com" che vi era nel plugin e mi da questo errore:

Codice PHP:
{
   
"error": {
      
"message""Unsupported get request. Please read the Graph API documentation at https://developers.facebook.com/docs/graph-api",
      
"type""GraphMethodException",
      
"code"100
   
}

Ho cambiato completamente il plugin e mi dà quest'altro errore: "Error code 4# - application request limit reached".

Possibile che solo facebook mi dia sti problemi?! Cioè... cavolo nel plugin vi sono: Twitter, G+, Youtube e Facebook. I primi 3 funzionano SEMPRE mentre facebook mi sta dando solo problemi. Non risolverò mai eh? xD

Preliator
25.07.2014, 14.29
Ohllallà com'è suscettibilein teoria dovrebbe fare il redirect automatico se si omette l'https e invece il fatto che non c'era, per wp, era come se indirizzasse ad un altro sito che ovviamente non conteneva le tue informazioni richieste... comunque dal debug sembra che il problema fosse prettamente di plugin. Quindi wp ne ovh c'entrava nulla... e difatto...

Epyka
24.07.2014, 09.39
Citazione Originariamente Scritto da Preliator
Si attivala in fondo al file config.php ma occhio perchè scomparirà la home e ci sarà l'elenco completo di tutti gli errori.
Stranamente la homepage è uscita e la lista degli errori erano in alto alla pagina (poco visibili) e gli altri sia negli articoli che nel footer. Copia-incolla:

Codice:
1) Strict Standards: Declaration of Quick_Count_List_Table::prepare_items() should be compatible with WP_List_Table::prepare_items() in /home/epyka/www/wp-content/plugins/quick-count/class-quick-count-list-table.php on line 6

2) Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/epyka/www/wp-includes/functions.php on line 3193

3) Strict Standards: call_user_func_array() expects parameter 1 to be a valid callback, non-static method WP_Widget_MiniMeta::register() should not be called statically in /home/epyka/www/wp-includes/plugin.php on line 470

4) Questo mi esce al posto dei titoli degli articoli: Notice: WP_User->id è stato chiamato con un argomento deprecato dalla versione 2.1! In alternativa utilizzare WP_User->ID.. in /home/epyka/www/wp-includes/functions.php on line 3193

5) Questi nel footer: Notice: Undefined index: class in /home/epyka/www/wp-content/plugins/minimeta-widget/app/widget-display.php on line 136

5.1) Strict Standards: call_user_func() expects parameter 1 to be a valid callback, non-static method MiniMetaWidgetParts::linkloginout_display() should not be called statically in /home/epyka/www/wp-content/plugins/minimeta-widget/app/widget-display.php on line 137

5.2) Strict Standards: Non-static method MiniMetaWidgetParts::ulopenclose() should not be called statically in /home/epyka/www/wp-content/plugins/minimeta-widget/app/widget-parts.php on line 187

5.3) Notice: Undefined variable: redirect in /home/epyka/www/wp-content/plugins/minimeta-widget/app/widget-parts.php on line 188

5.4) Strict Standards: Non-static method MiniMetaWidgetParts::styleclass() should not be called statically in /home/epyka/www/wp-content/plugins/minimeta-widget/app/widget-parts.php on line 190
Ne ho il footer pieno di questi errori!

Però non mi porta l'errore del "WP Remote Get" (ed il count di Facebook è tornato a 0 da 2 giorni...)

Oh. Mio. Dio!... Ho fatto una prova, così... tanto per provare un qualcosa di non richiesto... Ho immesso, oltre all'ID della pagina di Facebook richiesto, anche il "https", inserendo quindi non solo "ID PAGINA" ma: "https://www.facebook.com/IDPAGINA" ... funziona, per ora. Ma voglio attendere almeno 3 giorni prima di dichiarare il problema "risolto". Se funziona davvero potrebbe essere utile a molte persone che hanno avuto questo problema.

Preliator
23.07.2014, 21.48
Si attivala in fondo al file config.php ma occhio perchè scomparirà la home e ci sarà l'elenco completo di tutti gli errori.

Epyka
23.07.2014, 13.33
Va beh, chiudete va.

Epyka
22.07.2014, 09.00
Up 2...

Epyka
20.07.2014, 11.44
Citazione Originariamente Scritto da kenny992
Ciao Epyka,

Hai degli errori specifici in output dal widget?

Hai cambiato la costante define('WP_DEBUG', true), per attivare il debug di WP?
L'unico errore specifico (che trovo nel "System status" del plugin) che mi da è "WP Remote Get: wp_remote_get() failed. This may not work with your server."

Infatti oggi quell'errore è sparito: "wp_remote_get() was successful. ". Ma capita raramente che funzioni. Sono stato tipo 3-4 giorni con il count a 0 ed oggi invece funziona. Tutto da solo... Domani tornerà a 0 (quello che fa solitamente)

Per la costante: No, devo attivarla?

kenny992
18.07.2014, 16.01
Ciao Epyka,

Hai degli errori specifici in output dal widget?

Hai cambiato la costante define('WP_DEBUG', true), per attivare il debug di WP?

Epyka
18.07.2014, 14.46
UP...

Epyka
17.07.2014, 15.34
Hosting...

EDIT: Per l'esattezza: Web hosting Pro

filippobn
17.07.2014, 14.15
Ciao parli di hositng o un server dedicato? perché la differenza conta

Epyka
17.07.2014, 09.47
Nessuno?

Epyka
16.07.2014, 12.30
Salve tutti, spero che qualcuno del forum mi possa aiutare sotto questo aspetto. Sono da 3 giorni circa che cerco di venire a capo di questo problema ed oggi sono riuscito a capire quale è il problema: WP Remote Get: wp_remote_get() failed. This may not work with your server.

Se ho capito bene, questo comando non ha l'autorizzazione di sincronizzare i fan della pagina facebook con quelle del mio blog. In parole povere: Ho acquistato un tema per wordpress che, al suo interno, aveva un widget counter per i vari social. Ora: Ho inserito Twitter, G+ e Facebook e con mia grande sorpresa, i primi due fungono mentre per quanto concerne Facebook, i fan restano a 0. Ho già provato a mettere mano al codice sorgente del widget (nel folder del tema, php) e, grazie all'aiuto dello sviluppatore ho modificato il tutto inserendo a mano i fan e l'url della pagina: ha funzionato per circa 4 ore (il tempo di aggiornamento del widget) poi, oggi, è tornato a 0. Allora ho provato ad installare il plugin "Social count plus" che, nella sezione "statistiche", mi ha finalmente detto qual è il problema. Ora: Come posso fare per ovviare al problema? Posso modificare qualche permesso del mio server? O devo rinunciare ad avere le statistiche?

Grazie in anticipo per una eventuale risposta.