OVH Community, your new community space.

[ IPV6 ] Problemi configurazione IPV6 su server dedicato


linuxcafe
07.02.2015, 19.39
Salve, il problema del non raggiungimento del gateway sulla rete ovh e' comune sia per i failover ipv4 che per le /64 ipv6: il gateway si trova al di fuori della nostra subnet e necessita di una rotta statica per poter essere raggiunto. Sulle infrastrutture esx che amministro da ovh ho adottato una soluzione molto semplice ed efficace per poter utilizzare la /64 "splittata" in diverse /80 su diverse VM Debian con diversi ip failover.

step 1: disabilitare l'autoconfigurazione ipv6 tramite sysctl modificando /etc/sysctl.conf ed eseguendo poi il comando "sysctl -p" in shell
esempio: http://pastebin.com/D7bJSmyT

step 2: semplice script che tira su gli ipv6 su ogni vm eseguito da rc.local

esempio:
#!/bin/bash
ip -6 addr add 2001:41d0:c:*:1:0:0:0/80 dev eth0
ip -6 addr add 2001:41d0:c:*:1:0:0:1/128 dev eth0
ip -6 addr add 2001:41d0:c:*:1:0:0:2/128 dev eth0
route -A inet6 add 2001:41d0:c:*ff:ff:ff:ff:ff dev eth0
route -A inet6 add default gw 2001:41d0:c:*ff:ff:ff:ff:ff dev eth0

Soluzione da fabbro.... funziona perfettamente! Buona Giornata

claiudio
30.01.2015, 16.49
Ciao
Alla fine sei riuscito a risolvere?

camaran
23.01.2015, 09.51
prova così:

iface eth0 inet6 static
address 2001:41d0:a:44a5::1
netmask 64
post-up /sbin/ip -f inet6 route add 2001:41d0:a:44ff:ff:ff:ff:ff dev eth00
post-up /sbin/ip -f inet6 route add default via 2001:41d0:a:44ff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del default via 2001:41d0:a:44ff:ff:ff:ff:ff
pre-down /sbin/ip -f inet6 route del 2001:41d0:a:44ff:ff:ff:ff:ff dev eth0

Controlla che abbia messo ip e gateway corretti

LukeBo
22.01.2015, 17.37
Ciao a tutti,

scrivo nella speranza che qualcuno si sia imbattuto nel problema seguente e lo sia riuscito a risolvere, visto che il supporto tecnico ci sta rimbalzando da giorni e sembra brancolare nel buio.

Macchina virtuale Debian su host ESXI.

Come da indicazioni su http://guida.ovh.it/Ipv4Ipv6 e considerando che la classe ipv6 indicata sul manager è: 2001:41d0:a:44a5::/64
abbiamo configurato in /etc/network/interfaces:

iface eth0 inet6 static
address 2001:41d0:a:44a5::1
netmask 64

Se proviamo a fare ping6 verso quello che “dovrebbe” essere il gw (2001:41d0:a:44ff:ff:ff:ff:ff) non otteniamo risposta.
Ovviamente non funziona nemmeno il ping verso host esterni (abbiamo provato a mettere anche delle rotte esplicite verso il gw).

La cosa singolare è che la stessa identica configurazione su un altro macchina virtuale (identica come software ) su un altro server/host OVH funziona senza problemi.

Qualcuno ha qualche idea? Abbiamo ticket aperto da ormai una settimana e sembra che non se ne venga a capo.

La conf. dell'interfaccia

eth0 Link encap:Ethernet HWaddr 00:50:56:0c:3d:1c
inet addr:XX:XX:XX:XX Bcast:XX:XX:XX:XX Mask:255.255.255.255
inet6 addr: fe80::250:56ff:fe0c:3d1c/64 Scope:Link
inet6 addr: 2001:41d0:a:44a5::1/64 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:115791 errors:0 dropped:0 overruns:0 frame:0
TX packets:89923 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:14856542 (14.1 MiB) TX bytes:30394783 (28.9 MiB)

Tks!