OVH Community, your new community space.

mail() non funziona


torpado
17.02.2015, 12.12
Citazione Originariamente Scritto da PPM
Salve a tutti,
ho una Vps con CentOS e Plesk preinstallati.

Ho configurato (spero) correttamente DNS e creato uno spazio web via Plesk.
Successivamente ho attivato il servizio mail dal manager della Vps e creato da quello un account email per il dominio associato al sito su cui riscontro il problema.

Ora, già i primi problemi.
Se da Plesk creo un indirizzo email, questo non funziona per nulla.
Se lo creo (come ho fatto) direttamente dal manager, mando e ricevo la posta senza problemi, ma Plesk non vede l'indirizzo email.
Cerchiamo di chiarire i dettagli del problema:

-> sulla VPS hai Plesk

-> manager: intendi il manager Ovh?

-> quali server dns sono legati al dominio in questione?

PPM
17.02.2015, 09.49
Avete ragione anche voi, se non do indicazioni difficile potermi aiutare.

Posto gli errori da log Postfix:
Feb 17 09:30:19 vps133305 postfix/smtpd[8935]: connect from unknown[unknown]
Feb 17 09:30:19 vps133305 /usr/lib64/plesk-9.0/psa-pc-remote[8312]: Unable to i$
Feb 17 09:30:19 vps133305 postfix/smtpd[8935]: NOQUEUE: milter-reject: CONNECT $
Feb 17 09:30:19 vps133305 postfix/smtpd[8935]: lost connection after CONNECT fr$
Feb 17 09:30:19 vps133305 postfix/smtpd[8935]: disconnect from unknown[unknown]
Feb 17 09:31:49 vps133305 plesk sendmail[8963]: handlers_stderr: DATA REPLY:554$
Feb 17 09:31:49 vps133305 plesk sendmail[8963]: REJECT during call 'limit-out' $


E quelli sul hog httpd:
Mail handler 'limit-out' said: REPLY:554:5.7.0 The message could not be sent. Y$
Mail handler 'limit-out' said: REPLY:554:5.7.0 The message could not be sent. Y$

PPM
13.02.2015, 12.04
Salve a tutti,
ho una Vps con CentOS e Plesk preinstallati.

Ho configurato (spero) correttamente DNS e creato uno spazio web via Plesk.
Successivamente ho attivato il servizio mail dal manager della Vps e creato da quello un account email per il dominio associato al sito su cui riscontro il problema.

Ora, già i primi problemi.
Se da Plesk creo un indirizzo email, questo non funziona per nulla.
Se lo creo (come ho fatto) direttamente dal manager, mando e ricevo la posta senza problemi, ma Plesk non vede l'indirizzo email.

Però il problema per cui scrivo qui è che la funzione mail() di PHP 5.3 non funziona.
Su php.ini, sendmail_path è impostato come /usr/sbin/sendmail -t -i

Dunque sembra corretto.
ma la funzione.. non funziona

Qualcuno riesce ad aiutarmi?
Grazie in anticipo,
Cris