We are in the process of migrating this forum. A new space will be available soon. We are sorry for the inconvenience.

Virtualbox e Windows Server 2012 R2 non funziona bridge e IP Failover


filippobn
07.06.2015, 08.06
Salve;

Sai sto avendo lo stesso identico problema ma su promoxo creando una vm mi da lo stesso problema sui server di ovh stessa configurazione fatta sul server soyoustart va tranquillamente, Magari il supporto saprebbe dirci qualcosa in piu?

Saluti

Filippo

PFM
03.06.2015, 00.57
Buonasera,

sul mio server Centos ho Virtualbox ed ho creato una macchina virtuale su cui ho installato la mia licenza originale di Windows Server 2012 R2 con scheda di rete in modalitÓ bridge.

Non riesco a far accedere la macchina virtuale ad internet.

Lato Guest Windows Server 2012 R2 ho impostato la scheda di rete "Intel Pro/1000 MT Desktop (scheda con bridge, eth0) relativamente al TCP/IP su IPv4 come:

Indirizzo IP: Il mio IP Failover
Subnet Mask: 255.255.0.0
Gateway: Indirizzo principale del server, con .254 al posto dell'ultimo numero
DNS: ho impostato quelli di Google (8.8.8.8 e 8.8.4.4)

Ovviamente:

1 - Ho acquistato un IP Failover dedicato
2- Ho fatto generare il Mac Address Virtuale da pannello del server, e l'ho assegnato alla virtual machine nell'apposito pannello di configurazione di Virtualbox
3- Ho configurato lato Host il nuovo IP Failover seguendo la guida di OVH e creando una nuova periferica di rete "ifcfg-eth0:0" con i seguenti parametri:

DEVICE="eth0:0"
BOOTPROTO=static
IPADDR="il mio IP failover"
NETMASK="255.255.255.255"
BROADCAST="il mio IP failover"
ONBOOT=yes

Riavviato i servizi di rete con il comando:

service network restart

La cosa veramente STRANA Ŕ che se installo in Virtualbox una macchina virtuale "windows XP", utilizzando i medesimi parametri di rete (in Virtualbox ed all'interno della macchina Guest una volta avviata), essa funziona perfettamente in modalitÓ bridge, naviga su internet ed Ŕ raggiungibile dall'esterno (tramite IP failover).

Soltanto la virtual machine di Windows Server 2012 R2 sembrebbe NON riuscire a collegarsi ad internet in modalitÓ bridge e ad essere, quindi, raggiungibile dall'esterno tramite IP Failover.

Qualcuno saprebbe indicarmi cosa sbaglio per favore?

Grazie in anticipo.