OVH Community, your new community space.

Connection closed by foreign host.


Claudia
14.03.2016, 15.14
Ciao Alessandro, ti confermiamo che il tuo ticket è stato ricevuto dal nostro supporto!

Facci sapere come procede il tutto anche qui sul forum

alessandro1105
08.03.2016, 22.40
Ciao a tutti!

Ho un problema nell’utilizzare un client TCP e il mio sito hostato su ovh. La connessione funziona correttamente:

telnet api.mymicrobridge.com 80
Trying 94.23.64.40...
Connected to api.mymicrobridge.com.
Escape character is '^]'.

Il problema sussiste quando inizio ad inviare la richiesta: dopo la prima stringa il server disconnette il client dopo qualche secondo, senza darmi la possibilità di completare la richiesta e di ottenere la relativa risposta.

Inizio la richiesta:
telnet api.mymicrobridge.com 80
Trying 94.23.64.40...
Connected to api.mymicrobridge.com.
Escape character is '^]'.

Invio la prima stringa della richiesta
GET / HTTP/1.1

Attendo qualche secondo (il tempo di fare copia incolla circa 4/5 secondi) e il server disconnette il client con il messaggio “Connection closed by foreign host.”. Ho notato che anche riuscendo ad inviare la seconda stringa della richiesta la connessione viene disconnessa quasi immediatamente.

Il problema sussiste anche con ovh.com (al posto del mio indirizzo api.mymicrobridge.com), mentre non occorre con altri siti NON hostati da ovh.

Ad esempio con il classico google.com:
telnet google.com 80
Trying 216.58.214.46...
Connected to google.com.
Escape character is '^]'.

Invio la prima stringa della richiesta:
GET / HTTP/1.1

attendo una decina di secondi (la connessione rimane attiva):
Host: google.com
Connection: close
(invio aggiuntivo per completare la richiesta)

Chiedo aiuto a voi perché non so più dove sbattere la testa (ho aperto anche un ticket di supporto ma non ho ancora ricevuto una soluzione al problema)

Grazie mille a tutti